Thursday, April 9, 2009

Google Chrome not working / Google Chrome stopped working

Reactions: 
I had this really weird issue where google chrome stopped working on my laptop, did some search and I finally found this obscure post on google's own site asking the user to try something to make it work. Interestingly it did, the version for which the solution was written for was different but essentially the method is what is important.

The issue was that on clicking the chrome icon nothing happens, the browser does not load up, and the task manager does not show the process to be running. Not sure what triggered this though.


The solution is to go to the following path in your command prompt

C:\Documents and Settings\(user name)\Local Settings\Application Data\Google\Chrome\Application\(version number)\Installer

Run the following statement

setup.exe --rename-chrome-exe


quit the command prompt with an exit. Chrome started working for me after that, hope it works for you as well. The link of the google page from where I got this from is below

http://www.google.com/support/forum/p/Chrome/thread?tid=2680b41d121dc73a&hl=en


Do let me know if this has helped you, if your feeling generous you could donate a dollar via paypal :)

16 comments:

  1. Yes!! it worked for me!! :) thank you a lot!!! ^^

    ReplyDelete
  2. Thank you thank you thank you!! Worked perfectly!

    ReplyDelete
  3. Thank you for your help.. it worked for me too.

    ReplyDelete
  4. Good job man, 10x

    ReplyDelete
  5. Worked for me too, thanks. Bizarre issue.

    ReplyDelete
  6. Worked for me too, had to re-boot though.
    Thanks and how odd!!

    ReplyDelete
  7. Worked like a charm! Thanks so much!!

    ReplyDelete
  8. The only tricky bit is you must go into DOS using CMD rather than COMMAND, so you're able to use the long directory names.

    ReplyDelete
  9. Worked for me also on Win7, fantastic :-)

    ReplyDelete
  10. this did not worked...

    ReplyDelete
  11. hey frnds i am facing same problem, google chrome loads but doesn't do anything, it don't show any error message,
    i have tried reinstalling it again and again but that doesnt solve the problem, i have deleted registries and making new user profile, i not getting why its not working. other side my all other web browsers are working fine firefox, opera, IE....

    please google help me out, and as i can analysis that this is some kind of update or bug, please help me to fix up my chrome.

    Anuj Wadhwa.
    CCNA

    ReplyDelete
  12. Wow.. it really worked! Granted I had to follow a different path with Windows 7, but it's been more than a day and Chrome hasn't crashed once, when before it would crash every few minutes. Thanks a TON. I didn't want to have to return to Firefox or IE.

    ReplyDelete
  13. My beloved Chrome has been on the brink as well. It loads but doesn't connect. I get an error message saying: This webpage is not available. blah blah blah Error 10 (net::ERR_ACCESS_DENIED): Unknown error.

    So I checked the default properties for my web browsers and it seems that even though I put Chrome as the default browser, IE8 is retaining the file extensions for .mht, .mhtml, & .url files as its defaults and won't let me uncheck the boxes in the default settings to change it to Chromes file associations. WTF? Any solutions?

    ReplyDelete
  14. XP pro - did not work for me. Very upsetting. Now i'm looking for a new browser. Never had a problem with IE. Someone needs to be fired

    ReplyDelete
  15. Ok but what about mac? how do i fix it on an apple computer? (same problem)

    ReplyDelete